
业务遇到这个情况,在重启服务时,出现1986端口被占用而无法启动,非得等该端口释放后才启动成功。使用net.ipv4.ip_local_port_range参数,规划出一段端口段预留作为服务的端口,这种方法是可以解决当前问题,但是会有个问题,端口使用量减少了,当服务器需要消耗大量的端口号的话,比如反代服务器,就存在瓶颈了。最好的做法是将服务监听的端口以逗号分隔全部添加到ip_local_reserved_ports中,TCP/IP协议栈从ip_local_port_range中随机选取源端口时,会排除ip_local_reserved_ports中定义的端口,因此就不会出现端口被占用了服务无法启动。

1、安装方法一:yum#yum install -y dstat方法二:rpm官网下载地址:http://dag.wieers.com/rpm/packages/dstat #wget http://dag.wieers.com/rpm/packages/dstat/dstat-0.6.7-1.rh7.rf.noarch.rpm#rpm -ivh dstat-0.6.7-1.rh7.rf.noar

众所周知,IPv6是为了解决IPv4地址耗尽的问题,但是并不是每个人都在使用它,也不是所有的硬件支持它,取代IPv4是大趋所致迟早的事情,IPv4会在悠悠岁月中慢慢退出而不会一蹴而就的。在某些情况下,可能会发现禁用IPv6不仅仅会加快网络,还会有助于减少管理开销和提高安全级别。在CentOS6系统下,遇到最常见的问题就是curl: (6) Couldn‘t resolve host ‘www.ttlsa.com‘。解决办法可以参见http://www.ttlsa.com/html/3631.html不仅仅CURL会有这个问题,python的urllib2也有这个问题,报错的信息如下:urllib2.URLError:

1、ifstat是一个网络流量监测程序。能查看网卡的流出和流入的字节.概要:ifstat就像iostat/vmstat描述其它的系统状况一样,是一个统计网络接口活动状态的工具。参数:-l 监测环路网络接口(lo)。缺省情况下,ifstat监测活动的所有非环路网络接口。经使用发现,加上-l参数能监测所有的网络接口的信息,而不是只监测lo的接口信息,也就是说,加上-l参数比不加-l参数会多一个lo接口

MegaCli是一款管理维护硬件RAID软件,可以通过它来了解当前raid卡的所有信息,包括 raid卡的型号,raid的阵列类型,raid 上各磁盘状态,等等。通常,我们对硬盘当前的状态不太好确定,一般通过机房人员巡检来完成,有没有通过软件的方式来检查确定这个问题呢。MegaCli就可以做到,一般通过 MegaCli 的Media Error Count: 0 Other Error Count

习惯性的将一些临时文件放在tmp目录下,让其自然删除。同时,为了保证tmp目录不爆满,系统默认情况下每日会处理一次tmp目录文件,原理就是使用了tmpwatch。在系统最小安装情况下,这个功能是没有安装的。tmpwatch工具从指定的目录中递归地搜索并删除指定的目录中一段时间未访问的文件。

一、内容抓取被抓取机器A(各种系统,各种盒子,各种电视机):IP:192.168.100.111网关:192.168.100.24 (tcpdump执行机)抓取机器B:IP:192.168.100.24B机器:<code>#echo 1 > /proc/sys/net/ipv4/ip_forward</code>#iptables -t nat -A POSTROUT

公司的麻将版本又更新了,svn检出最新的文件,接着打包吧。Ant编译的时候也没出现什么问题,只是一直会有一个warning。今天特别想解决掉。现在ANT也不知道多少版本了,不过版本在更新整个问题还是同样存在. 配置不当必然出现这个问题.

但看nginx模块名ngx_http_access_module,很多人一定很陌生,但是deny和allow相比没一个人不知道的,实际上deny和allow指令属于ngx_http_access_module.我们想控制某个uri或者一个路径不让人访问,在nginx就得靠它了。

数据库的备份是极其重要的事情。如果没有备份,遇到下列情况就会抓狂:UPDATE or DELETE whitout where…table was DROPPed accidentally…INNODB was corrupt…entire datacenter loses power…从数据安全的角度来说,服务器磁盘都会做raid,MySQL本身也有主从、drbd等容灾机制,但它们都无法完全取代